Promedio de Notas – Excel

Una noche mublada, siendo muy tarde, tenia mucho frio, estaba solo, cansado, pero feliz porque estaba trabajando en un programa de matricula para un instituto. De pronto en la esquina inferior derecha, se asomo un mensajito k decia: edu dice: Hola sobrino, jeje era mi tio que me hizo una contribucion para este post. y el problema dice lo siguiente:
  • Calcular el promedio de cada alumno
  • Mostrar la condicion del alumno Aprobado o Desaprobado
  • Calcular el total de alumnos
  • Calcular el total de alumnos aprobados
  • Calcular el total de alumnos desaprobados.

Promedio de cada alumno: … emmh sabemos que el promedio devuelve la media aritmetica de los argumentos, los cuales deben ser numeros, matrices o referencias que contengan numeros, cuya formula es asi P= (E1 + E2 + E3 + … + En)/n , n=numero de elmentos. llevando al codigo del programa tenemos =PROMEDIO(C3;D3;E3;F3), cuya sintaxis es:

=PROMEDIO(numer1,numero2, …)

Condicion del alumno: su mismo nombre lo dice, Condicion y por lo tanto asumimos, que se trata de “If” o “Si” = verdadera => Proceso 1 “SINO” => Procedo 2 “Fin SI”; en excel “=SI” comprueba si se cumple una condicion y devuelve un valor si se evalúa como VERDADERO y otro valor si se evalúa como FALSO. llevando a lenguaje Excel =SI(G3>10,49;”Aprobado”;”Desaprobado”) donde “G3” es el Promedio, en este caso nuestra sintaxis en Excel será:

=SI(prueba_logica;valor_si_verdadero;valor_si_falso)

Calcular el total de alumnos: si pensarlo dos veces utilizamos la funcion CONTAR, puedo agregar una observacion, esta funcion solo cuenta celdas con numeros y los numeros que hay en la lista de argumentos, por eso tomo la primera columna de notas “N1” e ingresamos =CONTAR(C3:C12) . cuya sintaxis es:

=CONTAR(valor1,valor2, … )

Alumnos Aprobados y Desaprobados: Para resolver este problema tenemos que utilizar una funcion que nos permita contar solo ciertas celdas que cumplan cierta condicion, osea tendriamos que utilizar una CONTAR y SI, entonces utilizamos … CONTAR.SI k logino no?? hehehe … aplicando la sintaxis tendriamos lo siguiente …

=CONTAR.SI(H3:H12;”Aprobado”)

El Pseudo para excel es asi: =CONTAR.SI(Rango;Criterio). Eso es todo por hoy, hasta muy pronto, suerte y Byte’s !

2 comentarios

  1. ME podrian explicar como cuento las notas por ejemplo del 4.0 hasta 4.9 ?

  2. grax por intentar responderme😄
    pero ya averigue (enrealidad me dijeron😄 )
    es asi : =(CONTAR(E4:E33))-((CONTAR.SI(E4:E33;”<5,0"))+(CONTAR.SI(E4:E33;">5,9″)))

    solo le tienen que cambiar las celdas y los valores

    xau grax

Responder

Introduce tus datos o haz clic en un icono para iniciar sesión:

Logo de WordPress.com

Estás comentando usando tu cuenta de WordPress.com. Cerrar sesión / Cambiar )

Imagen de Twitter

Estás comentando usando tu cuenta de Twitter. Cerrar sesión / Cambiar )

Foto de Facebook

Estás comentando usando tu cuenta de Facebook. Cerrar sesión / Cambiar )

Google+ photo

Estás comentando usando tu cuenta de Google+. Cerrar sesión / Cambiar )

Conectando a %s

A %d blogueros les gusta esto: